Error with Pragma Toolkit

Aug 16, 2011 at 5:01 PM

I get the following error message when I run Pragma Toolkit:

 

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Threading.ThreadAbortException: Thread was being aborted.
   at System.Drawing.SafeNativeMethods.Gdip.GdipCreateTexture(HandleRef bitmap, Int32 wrapmode, IntPtr& texture)
   at System.Drawing.TextureBrush..ctor(Image image, WrapMode wrapMode)
   at System.Windows.Forms.ControlPaint.DrawBackgroundImage(Graphics g, Image backgroundImage, Color backColor, ImageLayout backgroundImageLayout, Rectangle bounds, Rectangle clipRect, Point scrollOffset, RightToLeft rightToLeft)
   at System.Windows.Forms.Control.PaintBackground(PaintEventArgs e, Rectangle rectangle, Color backColor, Point scrollOffset)
   at System.Windows.Forms.Control.PaintBackground(PaintEventArgs e, Rectangle rectangle)
   at System.Windows.Forms.Control.OnPaintBackground(PaintEventArgs pevent)
   at System.Windows.Forms.ScrollableControl.OnPaintBackground(PaintEventArgs e)
   at System.Windows.Forms.Control.PaintTransparentBackground(PaintEventArgs e, Rectangle rectangle, Region transparentRegion)
   at System.Windows.Forms.Control.PaintBackground(PaintEventArgs e, Rectangle rectangle, Color backColor, Point scrollOffset)
   at System.Windows.Forms.Control.PaintBackground(PaintEventArgs e, Rectangle rectangle)
   at System.Windows.Forms.Control.OnPaintBackground(PaintEventArgs pevent)
   at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
   at System.Windows.Forms.Control.WmPaint(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.235 (RTMGDR.030319-2300)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
PragmaToolKit
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Pragmasys/PragmaToolKit%201.2/PragmaToolKit.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.235 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.236 built by: RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.ServiceModel
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 built by: RTMRel
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.ServiceModel/v4.0_4.0.0.0__b77a5c561934e089/System.ServiceModel.dll
----------------------------------------
Microsoft.Xrm.Sdk
    Assembly Version: 5.0.0.0
    Win32 Version: 5.0.9688.1046
    CodeBase: file:///C:/Program%20Files%20(x86)/Pragmasys/PragmaToolKit%201.2/Microsoft.Xrm.Sdk.DLL
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.1 (RTMRel.030319-0100)
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Coordinator
Aug 20, 2011 at 10:11 AM

have you installed the .net framework 4  on your machine because it is require to run that tool.

Aug 25, 2011 at 7:57 AM

I am having the same issue. .net framework 4 is installed. I have 64bit Win7.

Coordinator
Aug 25, 2011 at 8:11 AM

Please install Microsoft Identity Framework for your Operating System

 

Aug 25, 2011 at 11:14 AM

Identity framework was also installed.

However, I have reinstalled both suggested frameworks and restarted.

Now the tool does not display error when opening, but it does not connect to CRM which is run in IFD mode. It says: Can't connect to CRM. Enter Valid Authentication.

When I use the same credentials for normal access through IE it works.

Any idea?

Coordinator
Aug 25, 2011 at 11:20 AM

Please send me server url & screenshots of getting connected to IFD

your CRM Server must be configured for IFD

 

Coordinator
Aug 25, 2011 at 11:25 AM

send me the error sceenshot

 

Aug 25, 2011 at 12:01 PM

Please find the screenshot attached.
2011/8/25 Pragmateam <notifications@codeplex.com>

From: Pragmateam

send me the error sceenshot

Read the full discussion online.

To add a post to this discussion, reply to this email (pragmatoolkit@discussions.codeplex.com)

To start a new discussion for this project, email pragmatoolkit@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com


Aug 25, 2011 at 12:15 PM
Pragmateam wrote:

send me the error sceenshot

 


Here is the screenshot: http://i.imm.io/8t7E.png

Coordinator
Aug 25, 2011 at 12:23 PM

ok I will check it & reply you soon

thanks

Coordinator
Aug 25, 2011 at 12:41 PM

Please download new toolkit exe from codeplex & check it I hope now it will work

please give your valuable reviews about our product & support

Regards,

Pragmateam

Aug 25, 2011 at 1:49 PM

Hi, I have installed the new version. It displays the same error for IFD connection.
In addition, when trying to connect to onpremise, it displays error Organization required even when I select the Organization.

Screenshot: http://i.imm.io/8tjP.png

 

Coordinator
Aug 25, 2011 at 1:59 PM
Edited Aug 25, 2011 at 2:03 PM

Just now I checked for onpremise it's working.

& for IFD we can't check because we don't have server configured for IFD. Is  your CRM Server is accessible from internet ?

if yes ,can you provide credentials for your CRM Server ?

Aug 25, 2011 at 2:14 PM

I can provide test credentials for you. Please contact me on my email: ibrc78@gmail.com

Sep 27, 2011 at 1:13 PM

hello,

First of all great tool!

I have just downloaded the new version and getting an error with the on premise connection. The Online Connection does work!

The error is "Organization required"

 

What can I do against that!

 

Best regards,

   Christoph

Coordinator
Sep 27, 2011 at 1:18 PM
Edited Sep 27, 2011 at 1:19 PM

please tell me the server url, and send me the screen shots about the error.

thanks

Sep 27, 2011 at 1:20 PM

the url is:

 

crm2011rc.dev.local

Coordinator
Sep 27, 2011 at 1:24 PM

Hi ,

Is the IFD or claim based authentication enable?

Because it looks like IFD or claim based url. In that case use IFD type authentication from menu.

thanks

Coordinator
Sep 27, 2011 at 1:29 PM

can you send me the screen shots of conection form.

Feb 22, 2012 at 9:05 AM

I am having the same issue. I installed the tool on my CRM server and the connection is successfull.

Net framework 4 is installed. But I can't see "Microsoft Identity Framework".

Can you send me the Microsoft download link please? I can't find it.

I have a 32 bit pc with a 64 bit windows 7.

Thanks in advance.

Coordinator
Feb 23, 2012 at 12:54 PM

Hi Simonap,

Please follow this link for downloading the “Microsoft download Framework”.

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17331

Regards,

Pragmateam

From: simonap [email removed]
Sent: Wednesday, February 22, 2012 3:35 PM
To: sudhanshu.gupta@pragmasys.in
Subject: Re: Error with Pragma Toolkit [pragmatoolkit:269287]

From: simonap

I am having the same issue. I installed the tool on my CRM server and the connection is successfull.

Net framework 4 is installed. But I can't see "Microsoft Identity Framework".

Can you send me the Microsoft download link please? I can't find it.

I have a 32 bit pc with a 64 bit windows 7.

Thanks in advance.